phyphox Forums

Full Version: Display Bug with multiple views in Arduino phyphox library Version 1.1.0
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello everybody,

i want to use the new view options, that were added to the Arduino phyphox BLE library with version 1.1.0, so i started with the example Code "CreateExperiment.ino" from the library examples.
But when i run the program on my Arduino Nano 33 BLE and connect via my iPhone, the phyphox-App doesn't show the expected experiment layout.
Instead of the two Views that are defined in the code, there are five Views present on the Phone (see attached screenshots).
All these Views are identical and display the elements, that are added to the first View, according to the Arduino code.
I didn't change a thing from the example code.

All new view options like e.g. the edit-field are working.
My problem ist, that only the first view, that get's added to the PhyphoxBleExperiment, will be displayed.
This issue does not appear with library version 1.0.6, but then i obviously can't use the new view options.

I'm using the following hard-/software:
-Arduino Nano 33 BLE
-Arduino IDE Version 2.0.3
-Arduino phyphox BLE library 1.1.1 (I already tried version 1.1.0 but it doesn't fix the issue)
-Apple iPhone 11 Pro with iOS 16.2
-Phyphox App Version 1.1.11

Can anyone tell me what's going on here ?

Thanks in advance
We are aware of one bug in the Arduino part. Could you please check if this change,, also fixes your problem?

Tweet content added: “It's just replacing “0”→“i” in, so you could technically fix it locally – if you find the file… Wink
Hi Jens, thanks for the quick reply.

This change does indeed fix my issue.

Thank you for your help.