This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

phyphox crashes while trying to connect to Puck.js
Congratulations for the phyphox app. It is really cool and a great idea also.

I tried to use puck.js with phyphox, following the steps indicated in phyphox’s wiki page.
However, after selecting puck.js in the list of phyphox’s Bluetooth devices, a window pops up saying
Bluetooth connection could not be opened.
Error for the device with name “”.
The error message window is displayed for a couple of seconds and afterwards phyphox crashes and restarts.

It is strange that on phyphox’s Bluetooth devices list, “Puck.js 45a1” name shows up. But after attempting the connection the device name doesn’t show up in the error message.
This problem occurs on a Huawei P8 (android 6.0).

There is no problem connecting to Puck.js from Espruino Web IDE, either from the same Huawei P8 or from a PC.

Do you know what can be the cause, or how can the Phyphox connection be debugged?
Restarting the smartphone and deleting all Bluetooth devices on the smartphone devices list, didn’t help.
I just checked on an Android 14 and Android 8 device and could not reproduce the problem. So, narrowing this down could be a bit tricky.

First of all, by following the description in the Wiki you mean that you scanned the QR code, selected one of the configurations and then selected the puck.js when phyphox scans for devices, right? Since version 1.1.12 the experiments from the QR code are shipped with phyphox, so you can do the same by selecting Bluetooth from the "+" menu. There you would have to select the device first, then you select the configuration and then you should be able to start a measurement. Do you have the same problem here?

Could you also try on a different Android phone to narrow down where we need to search for the difference of your setup (i.e. that it is not a different puck revision triggering a problem in phyphox)?
I tried also by selecting Bluetooth from the "+" menu->selecting the device (Puck.js)-> selecting one of experiments. But the measurement fails to start. The same happens after saving all the experiments, and starting from one of the puck.js list of experiments that was saved to the main phyphox interface.

After attempting several times to start a measurement, phyphox produced some error messages attached below. However this behavior was not reproducible. Most often phyphox just crashes. I tried also to reinstall phyphox, and update puck.js firmware to version 2.19 (initially was 2.17). No success.

However it was possible to connect to puck.js and measure from another smartphone running phyphox in Android 8.

Attached Files Thumbnail(s)
What I take from this is that it is either Android 6 specific or even device specific. This will make it very tricky to debug. Also, the error messages are very random indeed. It seems like the connection is "spotty" and some operations work while others fail randomly.

Until I find an Android 6 device to test this on, I can only think of one other thing to check at the moment: Is the phone connected to other Bluetooth devices? (Headphones or a smartwatch are typical candidates)
I can see on my phone that the bandwidth is intermittently reduced while my smartwatch is connected. I would not expect such basic problems as you are experiencing, but since this is an older device, checking this would not do any harm.

Forum Jump: