This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

Long time audio record
Hi~I would like to record an audio (about 5 seconds) and output the results as an Excel file. Phyphox audioscope function appears to be limited to 500ms blocks. 
I have used 'Editor' to change the max of 'duration to 5000ms. To decrease the size of whole data, I have also decreased the audio measurement rate to 8000Hz. I have also doubled the buffer size of audio output.
But sadly, my phone is still only able to show 500ms record.....
I don't kown where is the problem. Which setting do I forget to change?
Can anyone help me? Thank you so much.   Big Grin
Setting the rate to 8000 Hz will most likely not change anything because most phones only support 48000 Hz or 44100 Hz, so on most devices, phyphox will be forced to use 48000 Hz. Still, it is of course worth a try.

Also, I generally do neither recommend recording longer audio with phyphox nor exporting audio to Excel. Phyphox is not optimized for audio and Excel is not ideal to handle the resulting 240000 data points. However, since you seem to have gotten so far, I am mostly writing this for others who might read this discussion.

So, about your problem: Did you also change the input of the divide module, which originally has 26400000 at its input? Phyphox does not receive a timestamp with each sample, but needs to calculate the times on the x axis itself. 26400000/48000=550 gives the time axis in ms. So, you need to add a zero here and also make sure to increase the buffer at the ramp output. If you only did the latter, you are already recording 5 seconds, but the timestamp associated is just not correct. If you also did not change the buffer at the output, it will run out of x valus at 550 ms and cut of the rest of the recording.

Also take note, that the audio scope experiment is designed to act like a scope by recording 50ms extra to be able to cut a way some data at the beginning to emulate triggering. So, take care that the 26400000 actually matches the buffer size (times 1000 for ms instead of s) or your time axis will be slightly off.

Since you probably do not need the triggering on a 5 second recording, you can alternatively simply create a new experiment without all that "baggage". Just start over, set the sleep time on the main tab to 5s, add an audio input, create a ramp function going from 0 to 5 and connect the ramp as well as the audio input to a graph. Set both buffers to 240001 (the one is there as 0 and 5 are included in the ramp, alternatively it could run from 0 to 5-1/48000) and make sure to also add them in the export tab. You also want to check the "static" option on the connection from the ramp to the graph to avoid constant recalculation of 240001 values and maybe increase the sleep from 5 seconds to 5.5s to avoid cut of samples if the timing is not perfect or your phone gets a bit slow when plotting all the data.

Hope this help...

Forum Jump: