This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

open instead of add (1.1.6-beta1)
I am using 1.1.6-beta1 version and I tried to modify my program in
using period-module.
When I tried to add a new program (attached) phyphox opens it and blocks. I have a lot of applications in my collection..

Attached Files
.phyphox   Ballistic pendulum 4.phyphox (Size: 17.27 KB / Downloads: 494)
phyphox beta successfully opens your experiment on my smartphone (current iOS) and I could enter values or switch tabs. I do not have a SensorTag here, so there is not much more I could test.

Two strange things that I experience:
  • the experiment is not added to the experiment list or a corresponding question is raised,
  • tapping play gives a warning message that there is no bluetooth device connected, however, starts the experiment anyway and I cannot stop it …err… doing nothing.
Indeed, it is a bug in our Android version or a lack of safety guards. Phyphox executes the modules once even before the experiment is started to allow filling graphs with reasonable data even before starting, like for example the waveform in the tone generator experiment (we will give you more control about this soon...). Now, when your analysis modules are executed like this, the dx input of the periodicity is zero, causing an infinite loop in this module.

I will catch this in the next update of phyphox. Until then, you will have to make sure that the dx input is always larger than 0.

@Jens: The iOS version has a check to ensure that dx is larger than 0 (and at the moment we do not execute the modules early on iOS).

Forum Jump: