This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

I can't export data

I'm trying to export data from:
Sensor: Acceleration (without g)

Sensor: Acceleration with g
Mechanics: Spring

But I can't export it, I tried with Excel but it doesn't work, i try to send via Whats app, Google drive, copy to my folders, Bluetooth, nearby, etc.
On my device only woks from .CSV but I want them in Excel Cry

Also I tried to export it from remote  control, but it doesn't export it in any format (Included .CSV)

My device is a Xiaomi Redmi Note 9S  if it gives some info to you.

I would appreciate any help from the community here.

Thanks, Jason. Big Grin
Do you have Excel installed in your phone?
This could particularly happen for huge data sets in the sensor experiments as the binary Excel format is restricted to less then 64k rows. The spring experiment should not come close to this limit though.

The export fails silently, correct? How many rows do the .csv files comprise?

Not that it seems relevant: Android 11?
I have the same problem with one of my phones (samsung S4) even when the recording (does not matter from which sensor) is very short. When I try to export data via gmail in Excel format it tells "Couldn't attach file"...  I thought it is due to absence of Excel in this phone. Normally I am using .csv files and they are OK.

Attached Files
.zip   Acceleration without g 2021-06-16 (Size: 17.73 KB / Downloads: 338)
That's odd. I just tried on an Android 6 and an Android 12 phone and exporting Excel to gmail worked well on both. But I have the impression that we are looking at two different problems here.

@Jarsgon: Let's start with the remote control export, simply because it is easier to get a bit more information from this one. Could you press F12 in your browser and look for a tab called "console" before trying the export function. Then when exporting, do you see if there is an error message anywhere (typically accompanied by a red circle with a white "x" inside). - Sorry, this description is a bit vague, but F12 accesses the debug console on most browsers with slightly different layout.

@solid: Does Excel export work when sending to other apps? Have you ever used adb or a "logcat" app? These allow to access error logs from all apps and it might be interesting to see if something is logged by gmail when it fails to open the excel file.

To both of you: I assume that you are on the latest version of phyphox? (1.1.9 from April)

Forum Jump: