This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

invalid view
#1
All of a sudden I got an error at loading an experience which runned before : 

"line 47 invalid view"

Anyone knows what this means?    
Reply
#2
Could you please export the experiment from the menu – tap the three vertical dots on the right of the entry and then “share” – and post it here in an attachment.
Reply
#3
Jens, because the experiment doesn't load I cannot add this to the list and therefor cannot share.
But I attached the sketch Smile, and also a screenshot as it was working before.


Attached Files Thumbnail(s)
   

.zip   CVWaterTemp_v3.zip (Size: 1.11 KB / Downloads: 16)
Reply
#4
Hey everyone,

sorry for my late response, i had to take care of my newborn son =)

I checked the file you send me by mail - the problem is within the setUnitX method. Currently the phyphox library allows a max length of 5 characters (we might change this). Since you have a longer unit in all your graphs the library ignores the faulty graphs which results in a view with no graph left..

It looks like you used a shorter unit in your working example.

Cheers
Dominik
Reply
#5
Dominik, of course a new born son is more important than a question of an old man (72). Gratulations!

You are right, the working example used [min] instead of [uur.min] . I used a RTC clock and by formula managed to make a float of the time ( hours +minute/100)
The decimal point is the division between hours and minutes. By using [u.m] it it will work again.

I couldn't find the error in your documentation neither could I find the max 5 characters long label ? Or did I look in the wrong place.
Nevertheless thanks for your respons.

Harrie
Reply
#6
Stupid me: the Arduino IDE had no access to the download folder and opened another file. I should have spotted this…

The limit is unfortunately not documented. It looks that we entirely remove it with the next version.
Reply
#7
You can see this issue here in the source code:

https://github.com/phyphox/phyphox-ardui...ph.cpp#L4+

As Jens already mentioned  - we will remove this unnecessary limitation with the next update! We will also introduce a new feature that will allow the user to get the current time on the microcontroller through phyphox.

Dominik
Reply


Forum Jump: