This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

CC2541 (SensorTag 1st gen) support/issue
Hi everyone,

more or less by chance, I connected my 1st gen SensorTag CC2541 to phyphox and successfully performed a measurement (amb & ir temp). IR is messed up because of the missing calibration (CC2541 uses a tmp006, CC2560 a tmp007), but ambient works fine.

My old CC2541 was already advertising as I tried a new experiment so I accidentally chose it instead of the CC2650. Why was I so surprised? Because in any other test runs phyphox returned the attached errors (English one is android on a nexus 4 and German one is iOS 13 on an iPhone). I first thought this is because they completely differ regarding the gatt table, but both use the same base uuid F0000000-0451-4000-B000-000000000000 and for temperature:
Type        UUID    Access    Size (bytes)    
Data        AA01*    R/N    4
Notification        R/W    2
Configuration    AA02*    R/W    1
Period        AA03*    R/W    1
and even the same resolution: 10 ms. Range 300 ms (0x1E) to 2.55 sec (0xFF). Default 1 second (0x64).

So why did it work this time? The thing is, that I forgot to set the period in the bluetooth configuration. In any other cases I tried setting it and phyphox returned the errors. Immediately, I opened the standard IR temperature experiment from the phyphox editor and I was able to reproduce the issue: as long as phyphox tries to set a different period, the error is returned. As soon as I delete it from the configuration, it works. Am I missing something?

@phyphox team: is this a known issue? If you have the resources to also look into it and since we are practically neighbors (I'm from cologne) I'd be happy to bring/send one 1st gen SensorTag over to Aachen for further development!

In the meantime I'll try to adapt the standard IR temperature experiment to the tmp006 sensor and take a closer look at the other sensors in the CC2541's gatt table and compare them to the CC2650. Any help is much appreciated! Sebastian

PS: I used the CC2650 users guide and this one from the internet archive for the CC2541.

Attached Files Thumbnail(s)
Sorry, I missed your post and a colleague just drew my attention to it.

You are right. It seems like it should just work on the older SensorTag and I have no idea why it should fail. A first thought is that maybe the older SensorTag does not allow setting a rate before the sensor has been enabled, so maybe just switching the first two config entries might already help. But then again, the errors on Android and iOS suggest that the characteristic is not even available (even though both errors have a different wording, they are both triggered if the UUID is not in the list of characteristics), which I find very strange.

So, I see two options:
a) You can try the app nRF Connect to see the characteristic is available and if you can set it manually.
b) You can indeed send the SensorTag to me, so I can find the problem (I would suggest to contact me via in this case).
Hi Sebastian, thanks for the reply and no worries!

>>A first thought is that maybe the older SensorTag does not allow setting a rate before the sensor has been enabled, so maybe just switching the first two config entries might already help.

I have tried this, unfortunately it didn't work.

>> So, I see two options (...)

I think I'll do both Wink Check your inbox! Sebastian
quick update: 

I did a scan with the nRF app, as Sebastian mentioned, and it seems that the characteristic corresponding to the period does not even appear in the attribute table.

Excitingly, this does not affect all sensors, for the accelerometer, for example, the corresponding data is available in the attribute table.

I have two CC2541 and the board revision is 1.3 each and I've tried the firmwares 1.3 and 1.4.1. Does anyone have another version so we can compare?

Attached: screenshots and log files.

Attached Files Thumbnail(s)

.txt   CC2541_FW1-3_log.txt (Size: 14.42 KB / Downloads: 507)
.txt   CC2541_FW1-4-1_log.txt (Size: 15.94 KB / Downloads: 635)

Forum Jump: